Living On The Edge With Windows 7 and Office 2010

In preparation to release of beta of Visual Studio 10 and .Net framework 4 (due out this Tuesday for MSDN and Thursday for general public) I have installed Windows 7 x64 and MS Office 2010 Technical Preview on my Lenovo ThinkPad X61s laptop. It has Core2 Duo L7700 CPU, 3GB RAM and 30GB OCZ SSD hard drive. So far it has been a great mobile workhorse for Windows XP, and since I can’t risk my main workstation’s setup I decided to test the combo on X61s. It still feels a little like living on the edge, even though this isn’t my primary work tool.

First culprit I hit was that Google Chrome wasn’t working under 64-bit Windows 7 version. No matter what I did it was just displaying a blank page. Turns out the issue is already fixed in Developer channel build. For others, adding a –in-process-plugins to a shortcut should do the trick. Alternatively, if other shortcuts are still giving you headaches, here’s the fix I have found (from quite a few sources) to be working:

The registry keys to change:

* HKEY_CLASSES_ROOT\Applications\chrome.exe\shell\open\command
* HKEY_CLASSES_ROOT\ChromeHTML\shell\open\command
* HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\chrome.exe\shell\open\command
* HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ChromeHTML\shell\open\command

Each key needs to be changed from looking like
…\chrome.exe” — “%1″
to
…\chrome.exe”–in-process-plugins — “%1”

Next stop – Lenovo’s Vista drivers don’t always work for Windows 7, despite Microsoft’s assurances that whatever works in Vista will work in Win7. As of right now the two biggest problems that remain are the power gauge (still shows about an hour of charge right before going to hibernation) and trackpoint driver, that only works in classic Windows applications. Even though the trackpoint works in Firefox, both Safari and Chrome ignore the scrolling feature making the ThinkPad’s trackpoint effectively useless.

Windows XP virtual machine worked fine, although Windows 7 only allocates 256MB of memory for it, which is nearly not enough. Pitching it up to 1024MB made it work just right, although increases the VM’s startup time, if only by half a minute.

Another thing that came as a surprise (since I haven’t used Vista heavily) was that telnet application is missing. For some reason you have to go to Control Panel ->Programs and Features -> Turn Windows Features On and Off and pick Telnet (as well as old trivial FTP, while you’re at it) to get installed. Thankfully, you won’t need an installation DVD for that.

Also, you will have to adjust the CPU’s power settings to make sure your applications as well as virtual environment aren’t bogged down by them. For some unknown reason Win7 sets something around 5% CPU power for laptop running on battery. Therefore – anytime you plan on watching those YouTube videos on the couch the performance would be so low that you will be pushed to fetch that power cord. Alternatively – drum up CPU power in advanced power settings.

Since power setting in Windows 7 are a bit more granular than those you had before, you will have more control over how fast your battery is depleting. Given that, your mileage may and will vary, although I’ve noticed that under WinXP the same battery lasted about an hour longer. My perception is that this is mainly due to me being more active (since I install and tweak stuff heavily rather than use the laptop for average browsing or writing stuff) and that I tend to run screen brighter in Win7 than I did in XP.

One of the parts of Office 2010 that I was mainly interested in is Outlook. So far this is the most valuable tool in the whole suite, since I don’t use Excel macros heavily. I do, however, track a lot of things in Outlook, keep contact information and their history, e-mails, tasks and notes. Additionally, contacts, tasks and notes are easily synchronize with heavily customized Windows Mobile phone that I use. However, much to my disappointment, the only major change in Outlook was the ribbon menu that became even less intuitive and more cryptic. Since this is a Technology Preview version I can’t complain about all the images and icons that are missing, but overall I was definitely struggling to complete tasks I got used to doing in Office 2007. Since I’ve only spent about half a day tweaking things around, I guess I will have to make a separate post about other parts of the Office 2010. So far the IMAP accounts work fine, although I missed the new setting Outlook uses for SMTP server (it’s 587 now). Luckily I noticed it early enough to tweak my server to run exim on port 587. Also, csd+lfd had to be told that it’s okay if someone tries to use this port for inbound connection (outbound was already there). But these are minor nuissances that you only get to encounter once. Oh, and for those of us who were hoping – no, you can’t export e-mail account settings (including username and password) from Outlook 2010. Not in this version anyway.

Subjectively, Win7 x64 “feels” a little more sluggish on this setup that Win7 x86 felt on the same laptop with 120GB WD Scorpio on 5400 RPM. There’s a noticeable “drag” on things, but as I’ve said – this is just my subjective impression. Now I’m just going to wait couple of more days for betas of Visual Studio 10 and .Net 4.0 to see how things will work then.